MCreator 1.5.8 crashes when trying to export

7 posts / 0 new
Last post
Offline
Last seen: 1 year 3 weeks ago
Joined: 10/12/2015 - 01:01
Gems: 0
MCreator 1.5.8 crashes when trying to export

Iam trying to create my first mod, but everytime I try to export the mod, it goes for abour 15more secs and then crashes.

Here is the crash report:

BOOTING UP GRADLE...
Data loaded, MCreator gradle console ready [ver 1.007]! [boot took 3 milliseconds]
RIGHT click once to copy log to the clipboard or twice to clear the log.
===================================================================================================================================
Executing gradle command: clean build
Microsoft Windows [Version 10.0.10240]
(c) 2015 Microsoft Corporation. All rights reserved.
C:\Pylo\MCreator158>cd forge
C:\Pylo\MCreator158\forge>SET "JAVA_HOME=C:\Pylo\MCreator158\jdk\"
C:\Pylo\MCreator158\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
C:\Pylo\MCreator158\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
C:\Pylo\MCreator158\forge>SET "JAVA_OPTS=-Xmx256m -Xms200m"
C:\Pylo\MCreator158\forge>gradlew clean build
****************************
 Powered By MCP:            
 http://modcoderpack.com/   
 Searge, ProfMobius, Fesh0r,
 R4wk, ZeuX, IngisKahn, bspkrs
 MCP Data version : snapshot_20141130
****************************
:clean
:downloadClient SKIPPED
:downloadServer SKIPPED
:getVersionJson
:extractUserDev UP-TO-DATE
:mergeJars SKIPPED
:applyBinPatches SKIPPED
:downloadMcpTools SKIPPED
:extractMcpData UP-TO-DATE
:genSrgs SKIPPED
:deobfBinJar SKIPPED
:compileApiJava UP-TO-DATE
:processApiResources UP-TO-DATE
:apiClasses UP-TO-DATE
:sourceMainJava
[Fatal Error] scala-reflect-2.11.1.pom:2:1: Content is not allowed in prolog.
[Fatal Error] scala-swing_2.11-1.0.1.pom:2:1: Content is not allowed in prolog.
[Fatal Error] scala-xml_2.11-1.0.2.pom:2:1: Content is not allowed in prolog.
[Fatal Error] lzma-0.0.1.pom:2:1: Content is not allowed in prolog.
[Fatal Error] vecmath-1.5.2.pom:2:1: Content is not allowed in prolog.
[Fatal Error] trove4j-3.0.3.pom:2:1: Content is not allowed in prolog.
[Fatal Error] trove4j-3.0.3.pom:2:1: Content is not allowed in prolog.
[Fatal Error] icu4j-core-mojang-51.2.pom:2:1: Content is not allowed in prolog.
[Fatal Error] codecjorbis-20101023.pom:2:1: Content is not allowed in prolog.
[Fatal Error] codecwav-20101023.pom:2:1: Content is not allowed in prolog.
[Fatal Error] libraryjavasound-20101123.pom:2:1: Content is not allowed in prolog.
[Fatal Error] librarylwjglopenal-20100824.pom:2:1: Content is not allowed in prolog.
[Fatal Error] soundsystem-20120107.pom:2:1: Content is not allowed in prolog.
[Fatal Error] guava-17.0.pom:2:1: Content is not allowed in prolog.
[Fatal Error] guava-17.0.pom:2:1: Content is not allowed in prolog.
[Fatal Error] jinput-2.0.5.pom:2:1: Content is not allowed in prolog.
[Fatal Error] jinput-2.0.5.pom:2:1: Content is not allowed in prolog.
[Fatal Error] jutils-1.0.0.pom:2:1: Content is not allowed in prolog.
[Fatal Error] jutils-1.0.0.pom:2:1: Content is not allowed in prolog.
[Fatal Error] authlib-1.5.17.pom:2:1: Content is not allowed in prolog.
[Fatal Error] realms-1.6.1.pom:2:1: Content is not allowed in prolog.
[Fatal Error] log4j-api-2.0-beta9.pom:2:1: Content is not allowed in prolog.
[Fatal Error] log4j-api-2.0-beta9.pom:2:1: Content is not allowed in prolog.
[Fatal Error] lwjgl-2.9.1.pom:2:1: Content is not allowed in prolog.
[Fatal Error] lwjgl-2.9.1.pom:2:1: Content is not allowed in prolog.
[Fatal Error] lwjgl_util-2.9.1.pom:2:1: Content is not allowed in prolog.
[Fatal Error] lwjgl_util-2.9.1.pom:2:1: Content is not allowed in prolog.
[Fatal Error] twitch-6.5.pom:2:1: Content is not allowed in prolog.
[Fatal Error] scala-actors-2.11.0.pom:2:1: Content is not allowed in prolog.
:compileJava
FAILURE: Build failed with an exception.
* What went wrong:
Could not resolve all dependencies for configuration ':compile'.
> Could not resolve org.scala-lang.modules:scala-swing_2.11:1.0.1.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/org/scala-lang/modules/scala-swing_2.11/1....
      > Content is not allowed in prolog.
   > Could not HEAD 'https://libraries.minecraft.net/org/scala-lang/modules/scala-swing_2.11/...'. Received status code 403 from server: Forbidden
> Could not resolve org.scala-lang.modules:scala-xml_2.11:1.0.2.
  Required by:
      com.yourname.modid:forge:1.0
      com.yourname.modid:forge:1.0 > org.scala-lang:scala-compiler:2.11.1
   > Could not parse POM http://repo1.maven.org/maven2/org/scala-lang/modules/scala-xml_2.11/1.0....
      > Content is not allowed in prolog.
   > Could not HEAD 'https://libraries.minecraft.net/org/scala-lang/modules/scala-xml_2.11/1....'. Received status code 403 from server: Forbidden
> Could not resolve lzma:lzma:0.0.1.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/lzma/lzma/0.0.1/lzma-0.0.1.pom
      > Content is not allowed in prolog.
> Could not resolve java3d:vecmath:1.5.2.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/java3d/vecmath/1.5.2/vecmath-1.5.2.pom
      > Content is not allowed in prolog.
> Could not resolve net.sf.trove4j:trove4j:3.0.3.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/net/sf/trove4j/trove4j/3.0.3/trove4j-3.0.3...
      > Content is not allowed in prolog.
   > Could not parse POM https://libraries.minecraft.net/net/sf/trove4j/trove4j/3.0.3/trove4j-3.0...
      > Content is not allowed in prolog.
> Could not resolve com.ibm.icu:icu4j-core-mojang:51.2.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/com/ibm/icu/icu4j-core-mojang/51.2/icu4j...
      > Content is not allowed in prolog.
> Could not resolve net.sf.jopt-simple:jopt-simple:4.6.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/net/sf/jopt-simple/jopt-simple/4.6/jopt-si...
      > Resetting to invalid mark
   > Could not parse POM https://libraries.minecraft.net/net/sf/jopt-simple/jopt-simple/4.6/jopt-...
      > Resetting to invalid mark
> Could not resolve com.paulscode:codecjorbis:20101023.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/com/paulscode/codecjorbis/20101023/codec...
      > Content is not allowed in prolog.
> Could not resolve com.paulscode:codecwav:20101023.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/com/paulscode/codecwav/20101023/codecwav...
      > Content is not allowed in prolog.
> Could not resolve com.paulscode:libraryjavasound:20101123.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/com/paulscode/libraryjavasound/20101123/...
      > Content is not allowed in prolog.
> Could not resolve com.paulscode:librarylwjglopenal:20100824.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/com/paulscode/librarylwjglopenal/2010082...
      > Content is not allowed in prolog.
> Could not resolve com.paulscode:soundsystem:20120107.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/com/paulscode/soundsystem/20120107/sound...
      > Content is not allowed in prolog.
> Could not resolve io.netty:netty-all:4.0.15.Final.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/io/netty/netty-all/4.0.15.Final/netty-all-...
      > Resetting to invalid mark
   > Could not parse POM https://libraries.minecraft.net/io/netty/netty-all/4.0.15.Final/netty-al...
      > Resetting to invalid mark
> Could not resolve com.google.guava:guava:17.0.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/com/google/guava/guava/17.0/guava-17.0.pom
      > Content is not allowed in prolog.
   > Could not parse POM https://libraries.minecraft.net/com/google/guava/guava/17.0/guava-17.0.pom
      > Content is not allowed in prolog.
> Could not resolve org.apache.commons:commons-lang3:3.3.2.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/org/apache/commons/commons-lang3/3.3.2/com...
      > Resetting to invalid mark
   > Could not parse POM https://libraries.minecraft.net/org/apache/commons/commons-lang3/3.3.2/c...
      > Resetting to invalid mark
> Could not resolve commons-io:commons-io:2.4.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/commons-io/commons-io/2.4/commons-io-2.4.pom
      > Resetting to invalid mark
   > Could not parse POM https://libraries.minecraft.net/commons-io/commons-io/2.4/commons-io-2.4...
      > Resetting to invalid mark
> Could not resolve commons-codec:commons-codec:1.9.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/commons-codec/commons-codec/1.9/commons-co...
      > Resetting to invalid mark
   > Could not parse POM https://libraries.minecraft.net/commons-codec/commons-codec/1.9/commons-...
      > Resetting to invalid mark
> Could not resolve net.java.jinput:jinput:2.0.5.
  Required by:
      com.yourname.modid:forge:1.0
BUILD FAILED
   > Could not parse POM http://repo1.maven.org/maven2/net/java/jinput/jinput/2.0.5/jinput-2.0.5.pom
Total time: 18.52 secs
      > Content is not allowed in prolog.
   > Could not parse POM https://libraries.minecraft.net/net/java/jinput/jinput/2.0.5/jinput-2.0....
      > Content is not allowed in prolog.
> Could not resolve net.java.jutils:jutils:1.0.0.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/net/java/jutils/jutils/1.0.0/jutils-1.0.0.pom
      > Content is not allowed in prolog.
   > Could not parse POM https://libraries.minecraft.net/net/java/jutils/jutils/1.0.0/jutils-1.0....
      > Content is not allowed in prolog.
> Could not resolve com.mojang:authlib:1.5.17.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/com/mojang/authlib/1.5.17/authlib-1.5.17...
      > Content is not allowed in prolog.
> Could not resolve com.mojang:realms:1.6.1.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/com/mojang/realms/1.6.1/realms-1.6.1.pom
      > Content is not allowed in prolog.
> Could not resolve org.apache.commons:commons-compress:1.8.1.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/org/apache/commons/commons-compress/1.8.1/...
      > Resetting to invalid mark
   > Could not parse POM https://libraries.minecraft.net/org/apache/commons/commons-compress/1.8....
      > Resetting to invalid mark
> Could not resolve org.apache.logging.log4j:log4j-api:2.0-beta9.
  Required by:
      com.yourname.modid:forge:1.0
      com.yourname.modid:forge:1.0 > net.minecraft:launchwrapper:1.11
   > Could not parse POM http://repo1.maven.org/maven2/org/apache/logging/log4j/log4j-api/2.0-bet...
      > Content is not allowed in prolog.
   > Could not parse POM https://libraries.minecraft.net/org/apache/logging/log4j/log4j-api/2.0-b...
      > Content is not allowed in prolog.
> Could not resolve org.apache.logging.log4j:log4j-core:2.0-beta9.
  Required by:
      com.yourname.modid:forge:1.0
      com.yourname.modid:forge:1.0 > net.minecraft:launchwrapper:1.11
   > Could not parse POM http://repo1.maven.org/maven2/org/apache/logging/log4j/log4j-core/2.0-be...
      > Resetting to invalid mark
   > Could not parse POM https://libraries.minecraft.net/org/apache/logging/log4j/log4j-core/2.0-...
      > Resetting to invalid mark
> Could not resolve org.lwjgl.lwjgl:lwjgl:2.9.1.
  Required by:
      com.yourname.modid:forge:1.0
      com.yourname.modid:forge:1.0 > net.minecraft:launchwrapper:1.11
   > Could not parse POM http://repo1.maven.org/maven2/org/lwjgl/lwjgl/lwjgl/2.9.1/lwjgl-2.9.1.pom
      > Content is not allowed in prolog.
   > Could not parse POM https://libraries.minecraft.net/org/lwjgl/lwjgl/lwjgl/2.9.1/lwjgl-2.9.1.pom
      > Content is not allowed in prolog.
> Could not resolve org.lwjgl.lwjgl:lwjgl_util:2.9.1.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM http://repo1.maven.org/maven2/org/lwjgl/lwjgl/lwjgl_util/2.9.1/lwjgl_uti...
      > Content is not allowed in prolog.
   > Could not parse POM https://libraries.minecraft.net/org/lwjgl/lwjgl/lwjgl_util/2.9.1/lwjgl_u...
      > Content is not allowed in prolog.
> Could not resolve tv.twitch:twitch:6.5.
  Required by:
      com.yourname.modid:forge:1.0
   > Could not parse POM https://libraries.minecraft.net/tv/twitch/twitch/6.5/twitch-6.5.pom
      > Content is not allowed in prolog.
> Could not resolve net.sf.jopt-simple:jopt-simple:4.6.
  Required by:
      com.yourname.modid:forge:1.0 > net.minecraft:launchwrapper:1.11
   > Could not parse POM http://repo1.maven.org/maven2/net/sf/jopt-simple/jopt-simple/4.6/jopt-si...
      > Resetting to invalid mark
   > Could not parse POM https://libraries.minecraft.net/net/sf/jopt-simple/jopt-simple/4.6/jopt-...
      > Resetting to invalid mark
> Could not resolve commons-codec:commons-codec:1.9.
  Required by:
      com.yourname.modid:forge:1.0 > org.apache.httpcomponents:httpclient:4.3.3
   > Could not parse POM http://repo1.maven.org/maven2/commons-codec/commons-codec/1.9/commons-co...
      > Resetting to invalid mark
   > Could not parse POM https://libraries.minecraft.net/commons-codec/commons-codec/1.9/commons-...
      > Resetting to invalid mark
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

 

I have tried a clean install of Minecraft and MCreator and that didn't work. Please help! Thank you :)

Edited by: Gwilly330 on 10/12/2015 - 05:20


Offline
Last seen: 1 year 1 month ago
Joined: 12/09/2014 - 13:40
Gems: 0
send this to klemen

send this to klemen

SurfinDude's picture
Offline
Last seen: 1 year 6 months ago
Joined: 10/16/2015 - 06:45
Gems: 0
I have the same poblem does

I have the same poblem does any one know why? I looked around the web for about 20 minutes and no answers but things i already did and didnt work. heres what MCreator said when I tested minecraft client environment.

****************************
 Powered By MCP:             
 http://modcoderpack.com/    
 Searge, ProfMobius, Fesh0r,
 R4wk, ZeuX, IngisKahn, bspkrs
 MCP Data version : snapshot_20141130
****************************
:clean
:downloadClient
FAILURE: Build failed with an exception.
BUILD FAILED
* Whatjava.io.FileNotFoundException: C:\Pylo\MCreator\forge\.gradle\2.0\taskArtifacts\cache.properties (The system cannot find the file specified)
 went wrong:
Total time: 7.727 secs
> C:\Pylo\MCreator\forge\.gradle\2.0\taskArtifacts\cache.properties (The system cannot find the file specified)
* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
C:\Pylo\MCreator\forge>
Task completed with return code 0 in 8273 milliseconds
Task return code check OK!

 

(Ps: my minecraft launcher did not open.)

Offline
Last seen: 1 year 3 weeks ago
Joined: 10/12/2015 - 01:01
Gems: 0
Who is Klemen, and how do I

Who is Klemen, and how do I send it to him?

GH127's picture
Offline
Last seen: 5 months 3 weeks ago
Joined: 01/16/2015 - 19:00
Gems: -1
Klemen is the MCreator owner

Klemen is the MCreator owner/administrator(something like that) and im not sure how you send to him.Most of the problems are solved by the Mcreator community

Offline
Last seen: 1 year 3 weeks ago
Joined: 10/12/2015 - 01:01
Gems: 0
Well, Anyone know how to fix

Well, Anyone know how to fix this?

ModDevJ's picture
Offline
Last seen: 1 year 8 months ago
Joined: 10/01/2015 - 15:59
Gems: 0
Try to run MCreator as Admin,

Try to run MCreator as Admin, It doesn't work anymore for me but perhaps it works for you.

If this doesn't work backup your user folder and delete all the other folders and reinstall MCreator and after installing forge change the old user folder with the new user folder

That worked for me

Im 14 guys and from austria (thats a signature below comments) #lennface