Techne Model Problem :C

4 posts / 0 new
Last post
Offline
Last seen: 1 year 1 month ago
Joined: 02/17/2015 - 21:19
Gems: 0
Techne Model Problem :C

Hi i build a techne model and I added it to mcrator. When i wanna throw it to server , server have problem witch model. On Singleplayer model work well .

Code : 

>****************************
> Powered By MCP:             
> http://modcoderpack.com/    
> Searge, ProfMobius, Fesh0r, 
> R4wk, ZeuX, IngisKahn, bspkrs
> MCP Data version : unknown
>****************************
>:compileApiJava UP-TO-DATE
>:processApiResources UP-TO-DATE
>:apiClasses UP-TO-DATE
>:sourceMainJava
>:compileJava
>:processResources UP-TO-DATE
>:classes
>:jar
>:compileTestJava UP-TO-DATE
>:processTestResources UP-TO-DATE
>:testClasses UP-TO-DATE
>:test UP-TO-DATE
>:extractMcpData UP-TO-DATE
>:getVersionJson
>:extractUserDev UP-TO-DATE
>:genSrgs SKIPPED
>:reobf
>:assemble
>:check UP-TO-DATE
>:build
>BUILD SUCCESSFUL
>Total time: 21.471 secs
>C:\Pylo\MCreator156\forge>
>Task completed with return code 0 in 22434 milliseconds
>Task return code check OK!
>=========================================================================================================================
>Executing gradle command: runServer
>Microsoft Windows [Wersja 6.1.7601]
>Copyright (c) 2009 Microsoft Corporation. Wszelkie prawa zastrzeľone.
>C:\Pylo\MCreator156>cd forge
>C:\Pylo\MCreator156\forge>SET "JAVA_HOME=C:\Pylo\MCreator156\jdk\"
>C:\Pylo\MCreator156\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
>C:\Pylo\MCreator156\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
>C:\Pylo\MCreator156\forge>gradlew runServer
>****************************
> Powered By MCP:             
> http://modcoderpack.com/    
> Searge, ProfMobius, Fesh0r, 
> R4wk, ZeuX, IngisKahn, bspkrs
> MCP Data version : unknown
>****************************
>:compileApiJava UP-TO-DATE
>:processApiResources UP-TO-DATE
>:apiClasses UP-TO-DATE
>:sourceMainJava UP-TO-DATE
>:compileJava
>:processResources UP-TO-DATE
>:classes
>:jar
>:getVersionJson
>:extractUserDev UP-TO-DATE
>:extractNatives UP-TO-DATE
>:getAssetsIndex
>:getAssets
>:makeStart
>[ant:javac] warning: [options] bootstrap class path not set in conjunction with -source 1.6
>[ant:javac] 1 warning
>:runServer
>[17:45:24] [main/INFO] [GradleStart]: Extra: []
>[17:45:25] [main/INFO] [GradleStart]: Running with arguments: [--tweakClass, cpw.mods.fml.common.launcher.FMLServerTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker]
>[17:45:25] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLServerTweaker
>[17:45:25] [main/INFO] [LaunchWrapper]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLServerTweaker
>[17:45:25] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.CoremodTweaker
>[17:45:25] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLServerTweaker
>[17:45:25] [main/INFO] [FML]: Forge Mod Loader version 7.10.85.1291 for Minecraft 1.7.10 loading
>[17:45:25] [main/INFO] [FML]: Java is Java HotSpot(TM) Client VM, version 1.7.0_60, running on Windows 7:x86:6.1, installed at C:\Pylo\MCreator156\jdk\jre
>[17:45:25] [main/INFO] [FML]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
>[17:45:25] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.CoremodTweaker
>[17:45:25] [main/INFO] [GradleStart]: Injecting location in coremod cpw.mods.fml.relauncher.FMLCorePlugin
>[17:45:25] [main/INFO] [GradleStart]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
>[17:45:25] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
>[17:45:25] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
>[17:45:25] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
>[17:45:25] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
>[17:45:25] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
>[17:45:25] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
>[17:45:25] [main/ERROR] [FML]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
>[17:45:28] [main/ERROR] [FML]: FML appears to be missing any signature data. This is not a good thing
>[17:45:28] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
>[17:45:28] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
>[17:45:28] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraftforge.gradle.tweakers.AccessTransformerTweaker
>[17:45:28] [main/INFO] [LaunchWrapper]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalTweaker
>[17:45:28] [main/INFO] [LaunchWrapper]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweaker
>[17:45:29] [main/INFO] [LaunchWrapper]: Launching wrapped minecraft {net.minecraft.server.MinecraftServer}
>[17:45:32] [main/WARN] [FML]: =============================================================
>[17:45:32] [main/WARN] [FML]: MOD HAS DIRECT REFERENCE System.exit() THIS IS NOT ALLOWED REROUTING TO FML!
>[17:45:32] [main/WARN] [FML]: Offendor: net/minecraft/server/gui/MinecraftServerGui$1.windowClosing(Ljava/awt/event/WindowEvent;)V
>[17:45:32] [main/WARN] [FML]: Use FMLCommonHandler.exitJava instead
>[17:45:32] [main/WARN] [FML]: =============================================================
>[17:45:33] [Server thread/INFO]: Starting minecraft server version 1.7.10
>[17:45:33] [Server thread/WARN]: To start the server with more ram, launch it as "java -Xmx1024M -Xms1024M -jar minecraft_server.jar"
>[17:45:33] [Server thread/INFO] [MinecraftForge]: Attempting early MinecraftForge initialization
>[17:45:33] [Server thread/INFO] [FML]: MinecraftForge v10.13.2.1291 Initialized
>[17:45:33] [Server thread/INFO] [FML]: Replaced 183 ore recipies
>[17:45:33] [Server thread/INFO] [MinecraftForge]: Completed early MinecraftForge initialization
>[17:45:34] [Server thread/INFO] [FML]: Searching C:\Pylo\MCreator156\forge\eclipse\mods for mods
>[17:45:37] [Server thread/INFO] [TestEnvironmentMod]: Mod TestEnvironmentMod is missing the required element 'name'. Substituting TestEnvironmentMod
>[17:45:37] [Server thread/INFO] [FML]: Forge Mod Loader has identified 4 mods to load
>[17:45:38] [Server thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, TestEnvironmentMod] at CLIENT
>[17:45:38] [Server thread/INFO] [FML]: Attempting connection with missing mods [mcp, FML, Forge, TestEnvironmentMod] at SERVER
>[17:45:39] [Server thread/ERROR]: Encountered an unexpected exception
>java.lang.NoClassDefFoundError: net/minecraft/client/renderer/tileentity/TileEntitySpecialRenderer
>    at mod.mcreator.TestEnvironmentMod.<init>(TestEnvironmentMod.java:137) ~[TestEnvironmentMod.class:?]
>    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.7.0_60]
>    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57) ~[?:1.7.0_60]
>    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.7.0_60]
>    at java.lang.reflect.Constructor.newInstance(Constructor.java:526) ~[?:1.7.0_60]
>    at java.lang.Class.newInstance(Class.java:374) ~[?:1.7.0_60]
>    at cpw.mods.fml.common.ILanguageAdapter$JavaAdapter.getNewInstance(ILanguageAdapter.java:173) ~[ILanguageAdapter$JavaAdapter.class:?]
>    at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:486) ~[FMLModContainer.class:?]
>    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.7.0_60]
>    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[?:1.7.0_60]
>    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.7.0_60]
>    at java.lang.reflect.Method.invoke(Method.java:606) ~[?:1.7.0_60]
>    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74) ~[guava-17.0.jar:?]
>    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47) ~[guava-17.0.jar:?]
>    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322) ~[guava-17.0.jar:?]
>    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304) ~[guava-17.0.jar:?]
>    at com.google.common.eventbus.EventBus.post(EventBus.java:275) ~[guava-17.0.jar:?]
>    at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:208) ~[LoadController.class:?]
>    at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:187) ~[LoadController.class:?]
>    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.7.0_60]
>    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[?:1.7.0_60]
>    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.7.0_60]
>    at java.lang.reflect.Method.invoke(Method.java:606) ~[?:1.7.0_60]
>    at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74) ~[guava-17.0.jar:?]
>    at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47) ~[guava-17.0.jar:?]
>    at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322) ~[guava-17.0.jar:?]
>    at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304) ~[guava-17.0.jar:?]
>    at com.google.common.eventbus.EventBus.post(EventBus.java:275) ~[guava-17.0.jar:?]
>    at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:118) ~[LoadController.class:?]
>    at cpw.mods.fml.common.Loader.loadMods(Loader.java:492) ~[Loader.class:?]
>    at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:87) ~[FMLServerHandler.class:?]
>    at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:314) ~[FMLCommonHandler.class:?]
>    at net.minecraft.server.dedicated.DedicatedServer.startServer(DedicatedServer.java:120) ~[DedicatedServer.class:?]
>    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:445) [MinecraftServer.class:?]
>    at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:752) [MinecraftServer$2.class:?]
>Caused by: java.lang.ClassNotFoundException: net.minecraft.client.renderer.tileentity.TileEntitySpecialRenderer
>    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191) ~[launchwrapper-1.11.jar:?]
>    at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_60]
>    at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_60]
>    ... 35 more
>Caused by: java.lang.RuntimeException: Attempted to load class net/minecraft/client/renderer/tileentity/TileEntitySpecialRenderer for invalid side SERVER
>    at cpw.mods.fml.common.asm.transformers.SideTransformer.transform(SideTransformer.java:50) ~[forgeSrc-1.7.10-10.13.2.1291.jar:?]
>    at net.minecraft.launchwrapper.LaunchClassLoader.runTransformers(LaunchClassLoader.java:279) ~[launchwrapper-1.11.jar:?]
>    at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:176) ~[launchwrapper-1.11.jar:?]
>    at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_60]
>    at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_60]
>    ... 35 more
>[17:45:39] [Server thread/ERROR]: This crash report has been saved to: C:\Pylo\MCreator156\forge\eclipse\.\crash-reports\crash-2015-09-01_17.45.39-server.txt
>[17:45:39] [Server thread/WARN] [FML]: Can't revert to frozen GameData state without freezing first.
>[17:45:39] [Server thread/INFO] [FML]: Applying holder lookups
>[17:45:39] [Server thread/INFO] [FML]: Holder lookups applied
>[17:45:39] [Server thread/INFO] [FML]: The state engine was in incorrect state ERRORED and forced into state SERVER_STOPPED. Errors may have been discarded.
>[17:45:39] [Server thread/INFO] [FML]: The state engine was in incorrect state ERRORED and forced into state AVAILABLE. Errors may have been discarded.
>BUILD SUCCESSFUL
>Total time: 35.445 secs
>C:\Pylo\MCreator156\forge>
>Task completed with return code 0 in 36182 milliseconds
>Task return code check OK!

 

Edited by: michal2010 on 09/01/2015 - 17:58


Offline
Last seen: 1 year 5 months ago
Joined: 03/11/2015 - 21:09
Gems: 0
Techne is no longer in works

Techne is no longer in works with Mcreator do to the fact that MCreator is now using .jason files followin gmincrafts examples Techne uses .java so unless they make it to where it can be exported as a .jason file you can no longer use Techne to model I suggest using mr.cray fish's model creator make sure you have java 8 or it will not work! Sorry for the inconvinces!

 

GH127's picture
Offline
Last seen: 2 months 3 weeks ago
Joined: 01/16/2015 - 19:00
Gems: -1
Antwriter,mcreator still

Antwriter,mcreator still supports techne models for mobs only.And michal2010 said that in single player it is working fine.Unfortunely I dont know how to fix your problem.

Offline
Last seen: 10 months 3 weeks ago
Joined: 12/09/2014 - 13:40
Gems: 0
send this to klemen

send this to klemen