MCreator On Mac [Problem]

11 posts / 0 new
Last post
Offline
Last seen: 1 year 5 months ago
Joined: 08/17/2014 - 12:06
Gems: 0
MCreator On Mac [Problem]

Hello,

I am a mod maker on a mac but the problem is, when i click start client (to test the mod) it wont start

 

I hope you can fix this.

Thanks, Stijn



Offline
Last seen: 1 year 6 days ago
Joined: 08/08/2015 - 03:23
Gems: 0
This is a common problem,

This is a common problem, with multiple posts, but no one has answered. if you are looking for an answer soon, it will not come.

signed,

The guy who has also had this problem

Offline
Last seen: 1 year 5 months ago
Joined: 08/12/2015 - 05:09
Gems: 0
RE:This is a common problem,

I third this comment ....

BOOTING UP GRADLE...
Data loaded, MCreator gradle console ready [ver 1.007]! [boot took 14 milliseconds]
RIGHT click once to copy log to the clipboard or twice to clear the log.
===================================================================================================================================
Executing gradle command: cleanCache clean setupDecompWorkspace --refresh-dependencies
sudo: no tty present and no askpass program specified
Task completed with return code 1 in 373 milliseconds
===================================================================================================================================
Executing gradle command: clean build
sudo: no tty present and no askpass program specified
Task completed with return code 1 in 154 milliseconds
===================================================================================================================================
Executing gradle command: clean build
sudo: no tty present and no askpass program specified

Offline
Last seen: 1 year 5 months ago
Joined: 08/13/2015 - 20:39
Gems: 0
RE:RE:This is a common problem,

That is what's happening to me and even though I've looked everywhere, I can't find a solution! Please help!!

 

maxde6's picture
Offline
Last seen: 2 months 2 weeks ago
Joined: 04/08/2015 - 05:53
Gems: 0
probably not your macs fault

probably not your macs fault i use windows and the same thing happens i just upgrade to the next mcreator if there is a next one

 

Offline
Last seen: 1 year 6 days ago
Joined: 08/08/2015 - 03:23
Gems: 0
i use the latest, v1.5.7

i use the latest, v1.5.7

Offline
Last seen: 1 year 3 weeks ago
Joined: 08/21/2015 - 01:14
Gems: 0
This thing sucks, man. You

This thing sucks, man. You get all excited because you made an amazing mod, but then you cannot export or even test it. I also have this problem. I agree with above: let's just wait until the new version comes out if there is any

Offline
Last seen: 7 months 2 weeks ago
Joined: 08/20/2015 - 19:59
Gems: 0
Yeah, this happens to me too

Yeah, this happens to me too :(

Offline
Last seen: 1 year 2 months ago
Joined: 11/15/2015 - 07:11
Gems: 0
I had the same issue on a mac

I had the same issue on a mac. It basically means the program doesn't have admin permission to run. I fixed this by opening the .jar in a terminal command (Im sure there is an equivalent fix for PC)

1. Open terminal

2. type in "cd [your MCreator directory]" You can just type in cd, space, and click and drag your MCreator folder into the terminal, it will autofill.

3. type in "sudo java -jar MCreator.jar"

4. It will ask for a password. this is your computer admin password. it will look like you aren't typing anything, don't worry that is normal. Just enter password, hit enter, should solve your problem.

This basically runs the program in admin mode. You may have to do this every time you run the program. I hope this helps.

Offline
Last seen: 1 year 2 months ago
Joined: 11/16/2015 - 11:51
Gems: 0
Because Mac Sucks

Because Mac Sucks

Offline
Last seen: 1 month 4 weeks ago
Joined: 10/09/2015 - 03:00
Gems: 0
Try typing in this gradle

Try typing in this gradle command:

clean runClient

Or factory reset MCreator.