Java timeout error!

2 posts / 0 new
Last post
Offline
Last seen: 1 year 8 months ago
Joined: 06/23/2015 - 12:55
Gems: 0
Java timeout error!

SInce yesterday I've been trying to do a lot with MCreator and I've made a lot of good elements to export. However, when I try to export or recompile, this appears:

>BOOTING UP GRADLE...
>Data loaded, MCreator gradle console ready [ver 1.007]! [boot took 3 milliseconds]
>RIGHT click once to copy log to the clipboard or twice to clear the log.
>=========================================================================================================================
>Executing gradle command: build
>Microsoft Windows [Version 6.2.9200]
>(c) 2012 Microsoft Corporation. All rights reserved.
>C:\Pylo\MCreator156>cd forge
>C:\Pylo\MCreator156\forge>SET "JAVA_HOME=C:\Pylo\MCreator156\jdk\"
>C:\Pylo\MCreator156\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
>C:\Pylo\MCreator156\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
>C:\Pylo\MCreator156\forge>gradlew build
>Exception in thread "main" java.lang.RuntimeException: Timeout of 120000 reached waiting for exclusive access to file: C:\Users\Auni38\.gradle\wrapper\dists\gradle-2.0-bin\5h57m9vra0mjv9qs45oqtsb5c0\gradle-2.0-bin.zip
>    at org.gradle.wrapper.ExclusiveFileAccessManager.access(ExclusiveFileAccessManager.java:61)
>    at org.gradle.wrapper.Install.createDist(Install.java:44)
>    at org.gradle.wrapper.WrapperExecutor.execute(WrapperExecutor.java:126)
>    at org.gradle.wrapper.GradleWrapperMain.main(GradleWrapperMain.java:56)
>C:\Pylo\MCreator156\forge>
>Task completed with return code 0 in 120253 milliseconds
>Task return code check OK!

When exporting the return code doesn't even appear, and it does not even start. If someone could tell me how to fix this I would be very happy. I suspect is a permission problem, but when I ran my thing admin permissions, it all of a sudden just, quits...

So, any help would be appreciated!



Minekaxin's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: 06/12/2017 - 00:08
Gems: 4
did you find the solution?

did you find the solution?

 I have the same error...