"Run Client" error when starting client!

1 post / 0 new
Offline
Last seen: 1 year 7 months ago
Joined: 06/01/2014 - 07:42
Gems: 0
"Run Client" error when starting client!

Whenever I try to start the client, with or without any mods, I consistantly get this error.

Spoiler: Highlight to view
>Executing gradle command: runClient >Microsoft Windows [Version 6.1.7601] >Copyright (c) 2009 Microsoft Corporation. All rights reserved. >C:\Pylo\MCreator156>cd forge >C:\Pylo\MCreator156\forge>SET "JAVA_HOME=C:\Pylo\MCreator156\jdk\" >C:\Pylo\MCreator156\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe >C:\Pylo\MCreator156\forge>SET PATH=%JAVA_HOME%\bin\;%PATH% >C:\Pylo\MCreator156\forge>gradlew runClient >Exception in thread "main" java.lang.reflect.InvocationTargetException > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) > at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) > at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) > at java.lang.reflect.Method.invoke(Method.java:606) > at org.gradle.wrapper.BootstrapMainStarter.start(BootstrapMainStarter.java:30) > at org.gradle.wrapper.WrapperExecutor.execute(WrapperExecutor.java:127) > at org.gradle.wrapper.GradleWrapperMain.main(GradleWrapperMain.java:56) >Caused by: java.lang.NoClassDefFoundError: org/gradle/api/internal/classpath/ModuleRegistry > at org.gradle.launcher.GradleMain.main(GradleMain.java:23) > ... 7 more >Caused by: java.lang.ClassNotFoundException: org.gradle.api.internal.classpath.ModuleRegistry > at java.net.URLClassLoader$1.run(URLClassLoader.java:366) > at java.net.URLClassLoader$1.run(URLClassLoader.java:355) > at java.security.AccessController.doPrivileged(Native Method) > at java.net.URLClassLoader.findClass(URLClassLoader.java:354) > at java.lang.ClassLoader.loadClass(ClassLoader.java:425) > at java.lang.ClassLoader.loadClass(ClassLoader.java:358) > ... 8 more >C:\Pylo\MCreator156\forge> >Task completed with return code 0 in 328 milliseconds >Task return code check OK!


Please help >.<

EDIT : The following also cause the same error

-Recompiling

-Decompiling

-Running any gradle task

As well, the following CRASH MCreator

-Exporting to local Minecraft

-Exporting the mod to Zip/Rar

-Opening Techne (from the tools menu)

-Opening MCSkin (From the tools menu)

Edited by: Mystick Milotic on 05/23/2015 - 10:22