Minecraft won't run with my mod!

6 posts / 0 new
Last post
Offline
Last seen: 5 months 2 days ago
Joined: 01/31/2015 - 18:10
Gems: 0
Minecraft won't run with my mod!

I need help, whenever i put version 0.2.0 of my mod into my mods folder, and try to play this comes up:

---- Minecraft Crash Report ----
// This doesn't make any sense!
 
Time: 18/05/15 12:35
Description: There was a severe problem during mod loading that has caused the game to fail
 
cpw.mods.fml.common.LoaderException: java.lang.NoSuchMethodError: mod.mcreator.mcreator_enderWand$ItemenderWand.setMaxDamage(I)Lnet/minecraft/item/Item;
at cpw.mods.fml.common.LoadController.transition(LoadController.java:163)
at cpw.mods.fml.common.Loader.loadMods(Loader.java:522)
at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:218)
at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:480)
at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:878)
at net.minecraft.client.main.Main.main(SourceFile:148)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
Caused by: java.lang.NoSuchMethodError: mod.mcreator.mcreator_enderWand$ItemenderWand.setMaxDamage(I)Lnet/minecraft/item/Item;
at mod.mcreator.mcreator_enderWand$ItemenderWand.<init>(mcreator_enderWand.java:128)
at mod.mcreator.mcreator_enderWand.<clinit>(mcreator_enderWand.java:120)
at mod.mcreator.EnderCraft.<init>(EnderCraft.java:109)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at java.lang.Class.newInstance(Unknown Source)
at cpw.mods.fml.common.ILanguageAdapter$JavaAdapter.getNewInstance(ILanguageAdapter.java:173)
at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:506)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
at com.google.common.eventbus.EventBus.post(EventBus.java:275)
at cpw.mods.fml.common.LoadController.sendEventToModContainer(LoadController.java:212)
at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:190)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)
at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)
at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)
at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)
at com.google.common.eventbus.EventBus.post(EventBus.java:275)
at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:119)
at cpw.mods.fml.common.Loader.loadMods(Loader.java:511)
... 10 more
 
 
A detailed walkthrough of the error, its code path and all known details is as follows:
---------------------------------------------------------------------------------------
 
-- System Details --
Details:
Minecraft Version: 1.7.10
Operating System: Windows 7 (x86) version 6.1
Java Version: 1.8.0_45, Oracle Corporation
Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation
Memory: 67403080 bytes (64 MB) / 268087296 bytes (255 MB) up to 523501568 bytes (499 MB)
JVM Flags: 6 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx512M -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP v9.05 FML v7.10.130.1395 Minecraft Forge 10.13.3.1395 13 mods loaded, 13 mods active
mcp{9.05} [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed
FML{7.10.130.1395} [Forge Mod Loader] (forge-1.7.10-10.13.3.1395-1710ls.jar) Unloaded->Constructed
Forge{10.13.3.1395} [Minecraft Forge] (forge-1.7.10-10.13.3.1395-1710ls.jar) Unloaded->Constructed
BiblioCraft{1.10.1} [BiblioCraft] (BiblioCraft[v1.10.1][MC1.7.10].jar) Unloaded->Constructed
EnderCraft{0.2.0} [EnderCraft] (EnderCraft 0.2.0.zip) Unloaded->Errored
Baubles{1.0.1.7} [Baubles] (Baubles-1.7.10-1.0.1.7.jar) Unloaded->Constructed
ExtraUtilities{1.2.3} [Extra Utilities] (extrautilities-1.2.3.jar) Unloaded->Constructed
flansmod{4.9.0} [Flan's Mod] (Flans Mod-1.7.10-4.9.0.jar) Unloaded->Constructed
fossil{1.7.10 Build 6.4b} [Fossils and Archeology Revival] (Fossils_Archaeology(1.7.10).zip) Unloaded->Constructed
cfm{3.4.7} [§9MrCrayfish's Furniture Mod] (MrCrayfishFurnitureModv3.4.7(1.7.10).zip) Unloaded->Constructed
Thaumcraft{4.2.0.1} [Thaumcraft] (Thaumcraft-1.7.10-4.2.0.1.jar) Unloaded->Constructed
furniture{2.1} [furniture] (Vortes's Furniture Mod V2.1.zip) Unloaded->Constructed
witchery{0.24.1} [Witchery] (witchery-1.7.10-0.24.1.jar) Unloaded->Constructed
GL info: ' Vendor: 'Intel' Version: '4.3.0 - Build 10.18.14.4156' Renderer: 'Intel(R) HD Graphics 4400'
 
-----------------------------------------------------------------------------------------------------------------------------------------------------------------
 
Somebody please help me, and whenever I try to run MCreator 1.7.4, it just keeps saying connecting to the Pylo servers! and there is No MCreator154 folder on my computer! Someone help!


Offline
Last seen: 2 years 2 months ago
Joined: 03/03/2015 - 01:28
Gems: 0
The Endercraft might be your

The Endercraft might be your problem. The reason behide this is that its in the error stage rather than the constructed stage. Its just a guess.

Offline
Last seen: 1 year 9 months ago
Joined: 11/24/2015 - 01:23
Gems: 0
can you help when i export my

can you help when i export my mod it doesnt turn out thats it in my folder that i wanted it to be in and when i search my desktop i find it but its not a .ZIP file or a .JAR file PLS HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Offline
Last seen: 1 year 9 months ago
Joined: 11/24/2015 - 01:23
Gems: 0
IM BEGGING YOU!!!!!!!!!!!!!!!

IM BEGGING YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!! I EVEN LEARNED TO TYPE FAST BECAUSE OF THIS!!!!!!!!!!!!!!!!!!!!!!!!
 

Brich036's picture
Offline
Last seen: 8 months 1 week ago
Joined: 05/11/2015 - 03:57
Gems: 1
if its not a .JAR nor a .ZIP

if its not a .JAR nor a .ZIP then what is it?

go ahead and change it by right clicking on the folder and click "add to archive" then set it has a .ZIP and tell me how that goes

will always keep modding and never forget that :D

Offline
Last seen: 1 year 6 months ago
Joined: 03/07/2016 - 07:56
Gems: 0
I made a mod, but every time

I made a mod, but every time i put it in mods folder, it says it wot open it, why?