I made a Custom Model From Techne Wont Work

3 posts / 0 new
Last post
Offline
Last seen: 1 year 6 months ago
Joined: 08/21/2014 - 13:59
Gems: 0
I made a Custom Model From Techne Wont Work

i made a Custom model from techne but it wont work i tried many things that i thought will fix it bit i cant

can anyone help me pls, HERE IS THE ERROR

>=========================================================================================================================
>Executing gradle command: build
>Microsoft Windows [Version 6.0.6002]
>Copyright (c) 2006 Microsoft Corporation.  All rights reserved.
>C:\Pylo\MCreator155>cd forge
>C:\Pylo\MCreator155\forge>SET "JAVA_HOME=C:\Pylo\MCreator155\jdk\"
>C:\Pylo\MCreator155\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
>C:\Pylo\MCreator155\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
>C:\Pylo\MCreator155\forge>gradlew build
>****************************
> Powered By MCP:             
> Searge, ProfMobius, Fesh0r, 
> R4wk, ZeuX, IngisKahn, bspkrs
> MCP Data version : unknown
>****************************
>:downloadClient SKIPPED
>:downloadServer SKIPPED
>:getVersionJson
>:extractUserDev UP-TO-DATE
>:mergeJars SKIPPED
>:applyBinPatches SKIPPED
>:downloadMcpTools SKIPPED
>:extractMcpData UP-TO-DATE
>:genSrgs SKIPPED
>:deobfBinJar SKIPPED
>:compileApiJava UP-TO-DATE
>:processApiResources UP-TO-DATE
>:apiClasses UP-TO-DATE
>:sourceMainJava UP-TO-DATE
>C:\Pylo\MCreator155\forge\build\sources\java\mod\mcreator\mcreator_waterCatcher.java:230: error: ';' expected
>private final ModelWater Catcher model;
>                                ^
>C:\Pylo\MCreator155\forge\build\sources\java\mod\mcreator\mcreator_waterCatcher.java:230: error: <identifier> expected
>private final ModelWater Catcher model;
>                                      ^
>C:\Pylo\MCreator155\forge\build\sources\java\mod\mcreator\mcreator_waterCatcher.java:231: error: '(' or '[' expected
>public TileEntityCustomRenderer() {this.model = new ModelWater Catcher();}
>                                                               ^
>C:\Pylo\MCreator155\forge\build\sources\java\mod\mcreator\mcreator_waterCatcher.java:231: error: illegal start of expression
>public TileEntityCustomRenderer() {this.model = new ModelWater Catcher();}
>                                                                       ^
>C:\Pylo\MCreator155\forge\build\sources\java\mod\mcreator\mcreator_waterCatcher.java:231: error: not a statement
>public TileEntityCustomRenderer() {this.model = new ModelWater Catcher();}
>                                                                      ^
>C:\Pylo\MCreator155\forge\build\sources\java\mod\mcreator\mcreator_waterCatcher.java:261: error: '{' expected
>public static class ModelWater Catcher extends ModelBase
>                              ^
>6 errors
>:compileJava FAILED
>FAILURE: Build failed with an exception.
>* What went wrong:
>Execution failed for task ':compileJava'.
>> Compilation failed; see the compiler error output for details.
>* Try:
>Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
>BUILD FAILED
>Total time: 22.828 secs
>C:\Pylo\MCreator155\forge>
>Task completed with return code 0 in 23551 milliseconds
 
Edited by: SpellCaster on 03/28/2015 - 06:11


Offline
Last seen: 1 year 6 months ago
Joined: 08/21/2014 - 13:59
Gems: 0
Pls. can someone help me

Pls. can someone help me

Offline
Last seen: 1 month 1 day ago
Joined: 03/12/2015 - 11:51
Gems: 0
not sure if I can help but if

not sure if I can help but if you send me a copy of your techne save I can see if I see anything wrong with it sometimes its something small like forgetting to change a part name or something