Mod Not Exporting Need Help!

3 posts / 0 new
Last post
Offline
Last seen: 1 year 7 months ago
Joined: 03/25/2015 - 02:44
Gems: 0
Mod Not Exporting Need Help!

So I finished the first part of my mod yesterday, exported it, it worked perfectly. But now, today morning, when I try to export I got an error about VarList and GlobalEvents duplicated files or something and another one about VarList and GlobalEvents needing to be public. After that It would just give me an older version of the mod in a .zip file, without any new additions. Also if it helps the errors mentioned earlier also happened with recompiling. Now when I try to export, it just says: >Executing gradle command: build

 

I have been waiting for a few minutes now and nothing is happenening. Yesterday it took around 1 minute to export. Is it meant to do this? Please help thankx!!!

 

EDIT2: What I have tried:

-Deleting the file in the error

-Deleting the version of the file without the space before the .java part

-Deleting both files.

EDIT: It froze but made the file but it is still an old version of the mod. I have added like 20+ elements to the mod but they aren't there... Could it be because I added a creative tab then moved everything into the tab???

The recompile error says the error lies with: VarListCraftReloaded, GlobalEventsCraftReloaded, GlobalEventsCraftReloaded, VarListCraftReloaded.

I don't see how you can remove the global events and varlist and because each of them is there twice I think that this might be something to do with the duplicate error down below.

Got the error in the console here:

>BOOTING UP GRADLE...

>Data loaded, MCreator gradle console ready [ver 1.007]! [boot took 14 milliseconds]
>RIGHT click once to copy log to the clipboard or twice to clear the log.
>=========================================================================================================================
>Executing gradle command: build
>****************************
> Powered By MCP:             
> Searge, ProfMobius, Fesh0r, 
> R4wk, ZeuX, IngisKahn, bspkrs
> MCP Data version : unknown
>****************************
>:compileApiJava UP-TO-DATE
>:processApiResources UP-TO-DATE
>:apiClasses UP-TO-DATE
>:sourceMainJava
>/Users/Nic/Desktop/MCreator/MCreator 1.5.5 [1.7.10] Mac-Linux/forge/build/sources/java/mod/mcreator/mcreator_GlobalEventsCraftReloaded .java:133: error: class mcreator_GlobalEventsCraftReloaded is public, should be declared in a file named mcreator_GlobalEventsCraftReloaded.java
>public class mcreator_GlobalEventsCraftReloaded {
>       ^
>/Users/Nic/Desktop/MCreator/MCreator 1.5.5 [1.7.10] Mac-Linux/forge/build/sources/java/mod/mcreator/mcreator_GlobalEventsCraftReloaded.java:133: error: duplicate class: mod.mcreator.mcreator_GlobalEventsCraftReloaded
>public class mcreator_GlobalEventsCraftReloaded{
>       ^
>/Users/Nic/Desktop/MCreator/MCreator 1.5.5 [1.7.10] Mac-Linux/forge/build/sources/java/mod/mcreator/mcreator_VarListCraftReloaded .java:3: error: class mcreator_VarListCraftReloaded is public, should be declared in a file named mcreator_VarListCraftReloaded.java
>public class mcreator_VarListCraftReloaded {
>       ^
>/Users/Nic/Desktop/MCreator/MCreator 1.5.5 [1.7.10] Mac-Linux/forge/build/sources/java/mod/mcreator/mcreator_VarListCraftReloaded.java:3: error: duplicate class: mod.mcreator.mcreator_VarListCraftReloaded
>public class mcreator_VarListCraftReloaded{
>       ^
>4 errors
>:compileJava FAILED
>FAILURE: Build failed with an exception.
>* What went wrong:
>Execution failed for task ':compileJava'.
>> Compilation failed; see the compiler error output for details.
>* Try:
>Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
>BUILD FAILED
>Total time: 19.776 secs
>Task completed with return code 1 in 20529 milliseconds
 
Edited by: nicolasyodude on 03/25/2015 - 07:13


Offline
Last seen: 1 year 8 months ago
Joined: 03/12/2015 - 11:51
Gems: 0
I'm not sure about the

I'm not sure about the duplicate thing but that global event and variant list thing seems to be a recurring problem that no one has an answer for I had the same problem I posted it in the forum twice and got no response and someone else posted it as well with no resolution either i couldn't continue my work like that so I had to go into tools and reset mcreator which wiped everything out that may be your only option its a pain but if you still have everything you can always put it back on I really think its some kind of glitch I sent an error report you might want to as well

Offline
Last seen: 1 year 3 weeks ago
Joined: 10/09/2015 - 01:30
Gems: 0
I have the same globalevents

I have the same globalevents/variables problem without the duplicate thing. they say they need to be renamed or some shit but nothing is working. deleting them doesnt work. like darkdrakeshadow has said many people have posted about this here and elsewhere online and there is no response from anyone in terms of a solution other than to delete the files which doesnt work.

everytime i have an issue with mcreator the same thing happens, I google it, find that many people are complaining about the same issue, and no one responds with a solution.