MCreator Mod Not Running through Test Client or Forge

3 posts / 0 new
Last post
Offline
Last seen: 1 year 9 months ago
Joined: 08/19/2014 - 05:00
Gems: 0
MCreator Mod Not Running through Test Client or Forge

 

Hello. I have a mod ive been working on. Everything was fine yesterday, yet the test client crashes when I boot it up, as well as forge. Here is the log for the test client- The mod compiles and exports just fine btw

 
>===================================================================================================================
>Executing gradle command: runClient
>****************************
> Powered By MCP:             
> Searge, ProfMobius, Fesh0r, 
> R4wk, ZeuX, IngisKahn, bspkrs
> MCP Data version : unknown
>****************************
>:downloadClient SKIPPED
>:downloadServer SKIPPED
>:getVersionJson
>:extractUserDev UP-TO-DATE
>:mergeJars SKIPPED
>:applyBinPatches SKIPPED
>:downloadMcpTools SKIPPED
>:extractMcpData UP-TO-DATE
>:genSrgs SKIPPED
>:deobfBinJar SKIPPED
>:compileApiJava UP-TO-DATE
>:processApiResources UP-TO-DATE
>:apiClasses UP-TO-DATE
>:sourceMainJava UP-TO-DATE
>:compileJava
>:processResources UP-TO-DATE
>:classes
>:jar
>:extractNatives UP-TO-DATE
>:copyNativesLegacy UP-TO-DATE
>:getAssetsIndex
>:getAssets
>:makeStart SKIPPED
>:runClient
>[18:57:20] [main/INFO]: Extra: []
>[18:57:20] [main/INFO]: Running with arguments: [--userProperties, {}, --assetsDir, /private/var/root/.gradle/caches/minecraft/assets, --assetIndex, 1.7.10, --accessToken, {REDACTED}, --version, 1.7.10, --tweakClass, cpw.mods.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.GradleStartCommon$GradleStartTweaker]
>[18:57:20] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLTweaker
>[18:57:20] [main/INFO]: Using primary tweak class name cpw.mods.fml.common.launcher.FMLTweaker
>[18:57:20] [main/INFO]: Loading tweak class name net.minecraftforge.gradle.GradleStartCommon$GradleStartTweaker
>[18:57:20] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLTweaker
>[18:57:20] [main/INFO]: Forge Mod Loader version 7.10.85.1230 for Minecraft 1.7.10 loading
>[18:57:20] [main/INFO]: Java is Java HotSpot(TM) 64-Bit Server VM, version 1.8.0_25, running on Mac OS X:x86_64:10.9.5, installed at /Library/Java/JavaVirtualMachines/jdk1.8.0_25.jdk/Contents/Home/jre
>[18:57:20] [main/INFO]: Managed to load a deobfuscated Minecraft name- we are in a deobfuscated environment. Skipping runtime deobfuscation
>[18:57:20] [main/INFO]: Calling tweak class net.minecraftforge.gradle.GradleStartCommon$GradleStartTweaker
>[18:57:20] [main/INFO]: Injecting location in coremod cpw.mods.fml.relauncher.FMLCorePlugin
>[18:57:20] [main/INFO]: Injecting location in coremod net.minecraftforge.classloading.FMLForgePlugin
>[18:57:20] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
>[18:57:20] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.FMLDeobfTweaker
>[18:57:20] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
>[18:57:20] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLInjectionAndSortingTweaker
>[18:57:20] [main/INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
>[18:57:20] [main/ERROR]: The binary patch set is missing. Either you are in a development environment, or things are not going to work!
>[18:57:21] [main/ERROR]: FML appears to be missing any signature data. This is not a good thing
>[18:57:21] [main/INFO]: Calling tweak class cpw.mods.fml.relauncher.CoreModManager$FMLPluginWrapper
>[18:57:21] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.FMLDeobfTweaker
>[18:57:21] [main/INFO]: Loading tweak class name cpw.mods.fml.common.launcher.TerminalTweaker
>[18:57:21] [main/INFO]: Calling tweak class cpw.mods.fml.common.launcher.TerminalTweaker
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: java.lang.VerifyError: Call to wrong <init> method
>Exception Details:
>  Location:
>    net/minecraft/client/main/Main.<clinit>()V @4: invokespecial
>  Reason:
>    Type 'net/minecraft/client/main/Main$1' (constant pool 11) is not assignable to 'bgt' (constant pool 350)
>  Bytecode:
>    0x0000000: bb00 0b59 b701 5eb3 00df b1            
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: at java.lang.Class.getDeclaredMethods0(Native Method)
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: at java.lang.Class.privateGetDeclaredMethods(Class.java:2693)
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: at java.lang.Class.privateGetMethodRecursive(Class.java:3040)
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: at java.lang.Class.getMethod0(Class.java:3010)
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: at java.lang.Class.getMethod(Class.java:1776)
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: at net.minecraft.launchwrapper.Launch.launch(Launch.java:132)
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:78)
>[18:57:21] [main/INFO]: [java.lang.Throwable$WrappedPrintStream:println:748]: at GradleStart.main(GradleStart.java:45)
>:runClient FAILED
>Exception in thread "main" 
>FAILURE: Build failed with an exception.
>* What went wrong:
>Execution failed for task ':runClient'.
>BUILD FAILED
>> Process 'command '/Library/Java/JavaVirtualMachines/jdk1.8.0_25.jdk/Contents/Home/bin/java'' finished with non-zero>* Try:
 exit >Total time: 30.093 secs
value 1
>Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
>Task completed with return code 1 in 30955 milliseconds
 


Wes
Wes's picture
Offline
Last seen: 4 days 3 hours ago
Joined: 04/26/2014 - 16:35
Gems: 3
1.Copy Workspace

1.Copy Workspace
2.Remove last created mod part and run Client
3.Repeat Until Clinet Will run

Should Help

Offline
Last seen: 1 year 9 months ago
Joined: 08/19/2014 - 05:00
Gems: 0
RE:1.Copy Workspace

@Wes Ill try it