Can't find symbol error :/

10 posts / 0 new
Last post
Offline
Last seen: 8 months 1 day ago
Joined: 12/28/2014 - 14:44
Gems: 0
Can't find symbol error :/

I'm trying to make a demon boss. I made a skin, and a model, but I keep getting this error:

>C:\Pylo\MCreator154\forge\build\sources\java\mod\mcreator\mcreator_demonsHead.java:110: error: cannot find symbol
>        RenderingRegistry.registerEntityRenderingHandler(mcreator_demonsHead.EntitydemonsHead.class, new RenderLiving(new mcreator_demonsHead.ModelDemon(), 0){protected ResourceLocation getEntityTexture(Entity par1Entity){return new ResourceLocation("Skin.png");}
>                                                                                                                                             ^
>  symbol:   class ModelDemon
>  location: class mcreator_demonsHead
>1 error
>:compileJava FAILED
>FAILURE: Build failed with an exception.
>* What went wrong:
>BUILD FAILED
>Execution failed for task ':>> Compilation>Total time: 29.214 secs
 failed; see the compiler error output fo>* Try:
r details.
compileJava'.
>Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
>C:\Pylo\MCreator154\forge>
>Task completed with return code 0 in 29740 milliseconds

 

Can anyone help?

Thanks :)



Offline
Last seen: 1 year 12 months ago
Joined: 11/04/2014 - 10:21
Gems: 3
cant help but i have the same

cant help but i have the same error

>BOOTING UP GRADLE...
>Data loaded, MCreator gradle console ready [ver 1.007]! [boot took 0 milliseconds]
>RIGHT click once to copy log to the clipboard or twice to clear the log.
>===================================================================================================================
>Executing gradle command: build
>Microsoft Windows [Version 6.1.7601]
>Copyright (c) 2009 Microsoft Corporation. All rights reserved.
>C:\Users\jayjay\Desktop>cd forge
>C:\Users\jayjay\Desktop\forge>SET "JAVA_HOME=C:\Users\jayjay\Desktop\jdk\"
>C:\Users\jayjay\Desktop\forge>SET JAVA_EXE=%JAVA_HOME%\bin\java.exe
>C:\Users\jayjay\Desktop\forge>SET PATH=%JAVA_HOME%\bin\;%PATH%
>C:\Users\jayjay\Desktop\forge>gradlew build
>****************************
> Powered By MCP:
> http://mcp.ocean-labs.de/
> Searge, ProfMobius, Fesh0r,
> R4wk, ZeuX, IngisKahn, bspkrs
> MCP Data version : unknown
>****************************
>:compileApiJava UP-TO-DATE
>:processApiResources UP-TO-DATE
>:apiClasses UP-TO-DATE
>:sourceMainJava
>C:\Users\jayjay\Desktop\forge\build\sources\java\mod\mcreator\ModName.java:109: error: cannot find symbol
>mcreator_wonderFulForestDimension mcreator_1 = new mcreator_wonderFulForestDimension();
>^
> symbol: class mcreator_wonderFulForestDimension
> location: class ModName
>C:\Users\jayjay\Desktop\forge\build\sources\java\mod\mcreator\ModName.java:110: error: cannot find symbol
>mcreator_tropicalPinaple mcreator_2 = new mcreator_tropicalPinaple();
>^
> symbol: class mcreator_tropicalPinaple
> location: class ModName
>C:\Users\jayjay\Desktop\forge\build\sources\java\mod\mcreator\ModName.java:111: error: cannot find symbol
>mcreator_log mcreator_3 = new mcreator_log();
>^
> symbol: class mcreator_log
> location: class ModName
>C:\Users\jayjay\Desktop\forge\build\sources\java\mod\mcreator\ModName.java:112: error: cannot find symbol
>mcreator_tropical mcreator_4 = new mcreator_tropical();
>^
> symbol: class mcreator_tropical
> location: class ModName
>C:\Users\jayjay\Desktop\forge\build\sources\java\mod\mcreator\ModName.java:109: error: cannot find symbol
>mcreator_wonderFulForestDimension mcreator_1 = new mcreator_wonderFulForestDimension();
> ^
> symbol: class mcreator_wonderFulForestDimension
> location: class ModName
>C:\Users\jayjay\Desktop\forge\build\sources\java\mod\mcreator\ModName.java:110: error: cannot find symbol
>mcreator_tropicalPinaple mcreator_2 = new mcreator_tropicalPinaple();
> ^
> symbol: class mcreator_tropicalPinaple
> location: class ModName
>C:\Users\jayjay\Desktop\forge\build\sources\java\mod\mcreator\ModName.java:111: error: cannot find symbol
>mcreator_log mcreator_3 = new mcreator_log();
> ^
> symbol: class mcreator_log
> location: class ModName
>C:\Users\jayjay\Desktop\forge\build\sources\java\mod\mcreator\ModName.java:112: error: cannot find symbol
>mcreator_tropical mcreator_4 = new mcreator_tropical();
> ^
> symbol: class mcreator_tropical
> location: class ModName
>8 errors
>:compileJava FAILED
>FAILURE: Build failed with an exception.
>* What went wrong:
>Execution failed for task ':compileJava'.
>BUILD FAILED
>> Compilation failed; see the compiler error output for details.
>* Try:
>Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
>Total time: 7.785 secs
>C:\Users\jayjay\Desktop\forge>
>Task completed with return code 0 in 8377 milliseconds

Offline
Last seen: 1 year 12 months ago
Joined: 11/04/2014 - 10:21
Gems: 3
i have to reinstall this mod

i have to reinstall this mod maker over again ive already done it about 5 times.
*about 1 hour later*
nope 6 times

Offline
Last seen: 1 year 11 months ago
Joined: 08/17/2014 - 00:43
Gems: 0
Make sure the name for the

Make sure the name for the custom model is 100% same as in Techne.That fixed it for me.

Offline
Last seen: 5 months 1 week ago
Joined: 05/31/2016 - 16:48
Gems: 0
I made a mod and when I

I made a mod and when I compile it there is no problem but when I change of workspace MCretor can't find a symbol and there are many errors. I don't use Techne. How can I fix that ?

PS: I'm French so my English can be difficult to understand

Offline
Last seen: 5 months 1 week ago
Joined: 05/31/2016 - 16:48
Gems: 0
I find how to fix the problem

I find how to fix the problem !

Go in the MCreator file and search the folder : forge\buil\sources\java\mod\mcreator\

If the symbol isn't here, reload the workspace with the symbol copy it and paste it in the workspace wich tell that there is a problem.

Offline
Last seen: 1 week 1 day ago
Joined: 02/13/2016 - 00:36
Gems: 17
RE:I find how to fix the problem

@Aioniostheos What?

Offline
Last seen: 1 week 1 day ago
Joined: 02/13/2016 - 00:36
Gems: 17
RE:I find how to fix the problem

@Aioniostheos What?

Offline
Last seen: 1 week 1 day ago
Joined: 02/13/2016 - 00:36
Gems: 17
RE:I find how to fix the problem

@Aioniostheos What is a symbol?

9Tea's picture
Offline
Last seen: 1 week 5 days ago
Joined: 12/22/2016 - 08:13
Gems: 39
the only way ive found to fix

the only way ive found to fix the problem is to delete all the problem elements manualy and remake them, this fixes it and its not too hard to redo them beccause you already had everything done, you just need to copy it